Transient failures in remediation workflows

Incident Report for Workforce Experience Platform

Resolved

This has been resolved
Posted Jun 11, 2026 - 06:18 UTC

Monitoring

An unexpected surge in traffic to API endpoints used to return bios and driver update recommendations is causing transient intermittent failures. We are working to stabilize the service and are currently seeing traffic normalize. Will continue to monitor as we verify the fix.
Posted May 28, 2026 - 19:32 UTC
This incident affected: Device management [US] (Remediations).