Intermittent issues accessing URLs as part of Remediations service

Incident Report for Workforce Experience Platform

Resolved

This incident has been resolved,
Posted May 22, 2026 - 17:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2026 - 22:00 UTC

Update

We are continuing to investigate this issue.
Posted May 21, 2026 - 21:50 UTC

Update

This issue is resolved now, as we've adjusted cache rules to prevent request throttling. Team will continue to monitor.
Posted May 21, 2026 - 21:50 UTC

Investigating

We are investigating reports of intermittent issues accessing Remediations service URLs
Posted May 21, 2026 - 19:09 UTC
This incident affected: Device management [US] (Remediations).