WXP User Interface Outage

Incident Report for Workforce Experience Platform

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 00:16 UTC

Monitoring

Fix has been rolled out and all functionality has been restored. We'll continue to monitor the system.
Posted Jul 28, 2026 - 00:15 UTC

Update

We have identified a fix and are working on rolling it out.
Posted Jul 27, 2026 - 23:46 UTC

Identified

We are aware of an issue affecting access to WXP and working on resolving it. Users may experience login issues, intermittent connectivity, or reduced functionality while remediation efforts are underway. We will provide updates on the WXP status page as additional information becomes available. If problems persist after this outage has been resolved, please contact the WXP Support team for assistance at support@wxp.hp.com. Thank you for your patience and understanding.
Posted Jul 27, 2026 - 23:10 UTC
This incident affected: Authentication and user access [US] (Account management, Authorization, Licensing, subscriptions and entitlements, Sign In, User management) and Authentication and user access [EU] (Account management, Authorization, Licensing, subscriptions and entitlements, Sign In, User management).